WordPress Academic Blogger’s Toolkit

WordPress プラグインをインストールしたらホームページが見れなくなりました

 

プラグインの名前は “Academic Blogger’s Toolkit” ver 5.0.2 これまでが4.13.3だったのでメジャーな版数アップです。ちなみにWordpressは5.0.3。

エラーメッセージによると変数の宣言が受け付けられなくて、その後変数が無いために処理が滞っている模様。これはどうしようもないので、久しぶりにsftpでログインして、

~/public_html/wp-content/plugins/academic-bloggers-toolkit/

のディレクトリを削除して前のバージョンのプラグインに置き換えます。すると、何とか復旧しました。後になってサーバーの情報を確認すると、サーバーのPHP ver 5.6系だったのに対し、このプラグインはPHP ver 7.0 or higherを要求していました。ちゃんと調べてからアップデータしないといけないですね。

とりあえず自分の環境を忘れないように抜粋をメモメモ

CPU

Intel Xeon E5-2623 3.00GHz x2

メモリ

64GB

OS
Red Hat Enterprise Linux Server release 7.3(x86_64)
Apache
2.4系
GCC
4.8系
ruby
2系
Python
2.7系
PHP
5.6系
Perl
5.24
Java
J2SE8

 

 

コメントする

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください

Translate »